Login | Register
My pages Projects Community openCollabNet

Discussions > users > Current not running on RH enterprise 4.0

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

Back to topic list

Current not running on RH enterprise 4.0

Reply

Author "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov>
Full name "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov>
Date 2005-06-28 11:07:18 PDT
Message Hi,

I am trying to move our current server onto new hardware (actually the
hardware is identical but we wanted to move it onto its own system) and
upgrading the OS to 4.0WS.

Old System (working):
current - 1.5
OS - 3.0 AS
Postgresql - 7.3
Apache - 2.0
Python - 2.2.3

New System:
Tried current versions 1.5, 1.6 and 1.7
OS - 4.0 WS
Postgresql - 7.4
Apache - 2.0
Python - 2.3.4

Anytime I try to use cadmin to add a channel I get the following error
(with all versions 1.5, 1.6 and 1.7):

[root@current ~]# cadmin create_channel -l RHEL-3WS-i386 -a i386 -r 3WS
-n "Red Hat Enterprise Linux WS (v.3 for 32-bit)"
Traceback (most recent call last):
   File "/usr/sbin/cadmin", line 131, in ?
     main()
   File "/usr/sbin/cadmin", line 114, in main
     create_channel(sys.argv[2:])
   File "/usr/sbin/cadmin", line 80, in create_channel
     result = rpcServer.doCall(ser​ver.cadmin.createCha​nnel, chan)
   File "/usr/share/rhn/up2d​ate_client/rpcServer​.py", line 309, in doCall
     ret = apply(method, args, kwargs)
   File "/usr/lib/python2.3/​xmlrpclib.py", line 1029, in __call__
     return self.__send(self.__name, args)
   File "/usr/share/rhn/up2d​ate_client/rpcServer​.py", line 45, in
_request1
     ret = self._request(methodname, params)
   File "/usr/lib/python2.3/​site-packages/rhn/rp​clib.py", line 308, in
_request
     verbose=self._verbose
   File "/usr/lib/python2.3/​site-packages/rhn/tr​ansports.py", line 184,
in request
     return self._process_response(fd, connection)
   File "/usr/lib/python2.3/​site-packages/rhn/tr​ansports.py", line 212,
in _process_response
     return self.parse_response(fd)
   File "/usr/lib/python2.3/​site-packages/rhn/tr​ansports.py", line 236,
in parse_response
     return u.close()
   File "/usr/lib/python2.3/​xmlrpclib.py", line 742, in close
     raise Fault(**self._stack[0])
xmlrpclib.Fault: <Fault 1000: 'Function createChannel call blew up.
Bad week.'>

The connection to Postgresql works:
Jun 28 10:03:10 current postgres[29378]: [1-1] LOG: connection
received: host=[local] port=
Jun 28 10:03:10 current postgres[29378]: [2-1] LOG: connection
authorized: user=currentuser database=current

Am I missing a configuration file or something since the error message
is the same regardless of the version of current I am attempting to
run. I followed the same set up from the previous installation which
came together will little effort. I also went back to the online
documentation and followed all of the installation and set up steps to
make sure I was not skipping anything.

Any help will be appreciated.

Thank you,

Ryan

« Previous message in topic | 1 of 12 | Next message in topic »

Messages

Show all messages in topic

Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-28 11:07:18 PDT
     Re: Current not running on RH enterprise 4.0 Jack Neely <jjneely at pams dot ncsu dot edu> Jack Neely <jjneely at pams dot ncsu dot edu> 2005-06-28 12:22:52 PDT
         Re: Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-28 12:36:03 PDT
             Re: Current not running on RH enterprise 4.0 theslack Jack Neely 2005-06-28 13:27:30 PDT
                 Re: Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-28 13:53:16 PDT
                     Spoke to soon - Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-28 15:24:05 PDT
                         [Solved] Spoke too soon - Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-29 11:37:01 PDT
                             Re: [Solved] Spoke too soon - Current not running on RH enterprise 4.0 Jack Neely <jjneely at pams dot ncsu dot edu> Jack Neely <jjneely at pams dot ncsu dot edu> 2005-06-29 12:29:12 PDT
                                 Re: [Solved] Spoke too soon - Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-29 12:38:21 PDT
                                     Re: [Solved] Spoke too soon - Current not running on RH enterprise 4.0 Jack Neely <jjneely at pams dot ncsu dot edu> Jack Neely <jjneely at pams dot ncsu dot edu> 2005-06-29 15:44:20 PDT
                                         Re: [Solved] Spoke too soon - Current not running on RH enterprise 4.0 "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> "Ryan C dot Spaulding" <rspaulding at mail dot arc dot nasa dot gov> 2005-06-29 16:31:51 PDT
                                             Re: [Solved] Spoke too soon - Current not running on RH enterprise 4.0 Jack Neely <jjneely at pams dot ncsu dot edu> Jack Neely <jjneely at pams dot ncsu dot edu> 2005-06-29 20:54:35 PDT
Messages per page: