Login | Register
My pages Projects Community openCollabNet

Discussions > users > XML parse error in registration.add_hw_profile

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

Hide all messages in topic

All messages in topic

Re: XML parse error in registration.add_hw_profile

Reply

Author Geert van der Ploeg <geert at triple-it dot nl>
Full name Geert van der Ploeg <geert at triple-it dot nl>
Date 2003-09-09 04:59:23 PDT
Message ----- Original Message -----
From: "Hunter Matthews" <hunterm at tigris dot org>
To: <users at current dot ti​gris.org>
Sent: Thursday, September 04, 2003 7:17 PM
Subject: Re: XML parse error in registration.add_hw_profile


> This looks like a bug in that particular version of the _client_. It is
> what forms the XML that is sent to the server.
>
> Can you upgrade/downgrade the up2date package to some other version?

I don't have time to investigate this any further right now. A successful
workaround (for me) is to add the option "--nohardware" to the rhnreg_ks
command at registering.

Regards,

Geert


--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
For additional commands, e-mail: users-help at current dot tigris dot org

Re: XML parse error in registration.add_hw_profile

Reply

Author Geert van der Ploeg <geert at triple-it dot nl>
Full name Geert van der Ploeg <geert at triple-it dot nl>
Date 2003-09-04 12:45:03 PDT
Message ----- Original Message -----
From: "Hunter Matthews" <hunterm at tigris dot org>
To: <users at current dot ti​gris.org>
Sent: Thursday, September 04, 2003 7:17 PM
Subject: Re: XML parse error in registration.add_hw_profile


> This looks like a bug in that particular version of the _client_. It is
> what forms the XML that is sent to the server.
>
> Can you upgrade/downgrade the up2date package to some other version?

Done that already. Tried it first with a stock RH9 up2date client... (don't
know which version that is)
Same results.


Regards,
Geert


--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
For additional commands, e-mail: users-help at current dot tigris dot org

Re: XML parse error in registration.add_hw_profile

Reply

Author hunterm
Full name Hunter Matthews
Date 2003-09-04 10:17:24 PDT
Message This looks like a bug in that particular version of the _client_. It is
what forms the XML that is sent to the server.

Can you upgrade/downgrade the up2date package to some other version?


On Thu, 2003-09-04 at 04:23, Geert van der Ploeg wrote:
> Forgot to mention:
> Server (as well as client, as it is the same machine :-) ) version is: stock
> RH 9, only with new up2date-client (3.1.23.2).
>
> Regards,
> Geert
>
>
> --------------------​--------------------​--------------------​---------
> To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
> For additional commands, e-mail: users-help at current dot tigris dot org
--
Hunter Matthews Unix / Network Administrator
Office: BioScience 145/244 Duke Univ. Biology Department
Key: F0F88438 / FFB5 34C0 B350 99A4 BB02 9779 A5DB 8B09 F0F8 8438
Never take candy from strangers. Especially on the internet.


--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
For additional commands, e-mail: users-help at current dot tigris dot org

Re: XML parse error in registration.add_hw_profile

Reply

Author Geert van der Ploeg <geert at triple-it dot nl>
Full name Geert van der Ploeg <geert at triple-it dot nl>
Date 2003-09-04 01:23:24 PDT
Message Forgot to mention:
Server (as well as client, as it is the same machine :-) ) version is: stock
RH 9, only with new up2date-client (3.1.23.2).

Regards,
Geert


--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
For additional commands, e-mail: users-help at current dot tigris dot org

XML parse error in registration.add_hw_profile

Reply

Author Geert van der Ploeg <geert at triple-it dot nl>
Full name Geert van der Ploeg <geert at triple-it dot nl>
Date 2003-09-04 01:21:17 PDT
Message Hi all,

After some bad experience with the 1.5.5 version, I'm now deploying a 1.4.4
version server.
But, in the process of registering the server itself to Current, the
following occured:

In short:
======
I think there's an error in the XML-part which contains the hardwarelist:
...
<member>
<name>usbproto​col</name>
<value><str​ng></value>​
</member>
<member>
....

Either the string "<strng>" should be encoded (if "<strng>" is really meant
to be sent), or it should be an empty element...
But this way, the XML isn't well-formed.


More info:
=======

Client-side output of rhnreg_ks:

Traceback (most recent call last):
  File "/usr/sbin/rhnreg_ks", line 304, in ?
    main()
  File "/usr/sbin/rhnreg_ks", line 289, in main
    rhnreg.sendHardware(systemId, hardwareList)
  File "/usr/share/rhn/up2d​ate_client/rhnreg.py​", line 329, in sendHardware
    rpcServer.doCall(s.r​egistration.add_hw_p​rofile, systemId, hardwareList)
  File "/usr/share/rhn/up2d​ate_client/rpcServer​.py", line 170, in doCall
    raise up2dateErrors.Commun​icationError(e.errms​g)
up2dateErrors.Commun​icationError: Error communicating with server. The
message was:
Bad Request



Serverside output (current.log):

EXCEPTION in /usr/share/current/c​urrent_apache.py, handler(), 191
[logException()]
Traceback (most recent call last):
  File "/usr/share/current/​current_apache.py", line 187, in handler
    params, method = xmlrpclib.loads(data)
  File "/usr/lib/python2.2/​xmlrpclib.py", line 804, in loads
    p.feed(data)
  File "/usr/lib/python2.2/​xmlrpclib.py", line 390, in feed
    self._parser.Parse(data, 0)
ExpatError: not well-formed (invalid token): line 1054, column 25
Sep 04 10:20:46 Couldn't decode XMLRPC call.



See the attached file for the complete HTTP-conversation.


Thanks,
Geert
Attachments
Messages per page: