Login | Register
My pages Projects Community openCollabNet

Discussions > users > Re: up2date reports "No compatible channels found for client"

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

Back to topic list

Re: up2date reports "No compatible channels found for client"

Reply

Author theslack
Full name Jack Neely
Date 2006-05-04 07:40:36 PDT
Message You created your channel with an invaild arch string. You used
"IA-32" where you need to use "i386"

Ex:

    # cadmin create_channel --name "Red Hat 7.2" --label rhl7.2 --arch i386 \
        --release 7.2 --description "Red Hat Linux version 7.2"

The value for arch must match what RPM believes is the base arch for
the system. So for ia32/i686 machines that's "i386". For EM64t or
Opterons use "x86_64".

Also, your log file has some exceptions logged in it that shouldn't
happen. Current deletes all the files in the CURRENT_DIR and then
re-creates the needed links and files. When Current is creating the
links for you its getting "[Errno 17] File exists" errors. You may
want to delete all the files in CURRENT_DIR/www/CHAN​NEL/getPackage/
and then rescan the channel.

Jack

« Previous message in topic | 2 of 3 | Next message in topic »

Messages

Show all messages in topic

up2date reports "No compatible channels found for client" marafa Mohammed Arafa 2006-05-04 04:08:53 PDT
     Re: up2date reports "No compatible channels found for client" theslack Jack Neely 2006-05-04 07:40:36 PDT
         Re: up2date reports "No compatible channels found for client" theslack Jack Neely 2006-05-04 07:42:33 PDT
Messages per page: