Login | Register
My pages Projects Community openCollabNet

Discussions > users > RE: 8.0 client crashing w/ 1.4.4rc1 Server running on 7.3

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

2020-03-13: This site is going to be decommissioned and shut down very soon. Please copy and archive any data you wish to keep ASAP

Back to topic list

RE: 8.0 client crashing w/ 1.4.4rc1 Server running on 7.3

Reply

Author Erik Williamson <erik at cpsc dot ucalgary dot ca>
Full name Erik Williamson <erik at cpsc dot ucalgary dot ca>
Date 2003-05-30 12:58:32 PDT
Message Thanks so much for pointing this out. Patch applied, 8.0 clients are
good to go - Current rocks!

-----Original Message-----
From: Draco Benden [mailto:sschmit at cfl dot rr dot com]
Sent: Friday, May 30, 2003 11:25 AM
To: users at current dot tigris dot org
Subject: Re: 8.0 client crashing w/ 1.4.4rc1 Server running on 7.3

On Fri, May 30, 2003 at 11:01:51AM -0600, Erik Williamson wrote users:
> I recently moved up to 1.4.4rc1 to get that bleeding-edge 8.0 and 9
> support. RH 9 clients work wonderfully, as do all 7.x versions. My
> problem is 8.0 - when I run 'up2date', I get the results at the bottom
> of this mail. When I run 'cadmin checkdb' and 'cadmin checkperms',
There
> are no complaints. The client config file points to the right server
-
> (https://mirror.cpsc.​ucalgary.ca/XMLRPC - if you want to try it out)
>
> Here's the output from up2date:
>
> Traceback (most recent call last):
<snip>
> xml.parsers.expat.ExpatError: no element found: line 1, column 0

This is bug #20: <http://current.tigri​s.org/issues/show_bu​g.cgi?id=20>
There's a patch attached to that report which hunter hasn't had a chance
to look at but works for me (it should, I wrote it). The patch is
against
the devel version, but it will still apply to 1.4.4rc1.

Even with that patch, you're not going to see the problem on the client
side--what's happening is that the server thread crashed (an exception
was
raised) and is sending a Fault (XML-RPC exception) to the client.`

You need to look at the server-side logs and see what actually happened.
*THAT* traceback is the one we need to figure out what went wrong. You
may have to increase the log level to get useful output.

--
draco
"I know you think you thought you knew what you thought I said,
but I'm not sure you understood what you thought I meant." -- fortune


--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
For additional commands, e-mail: users-help at current dot tigris dot org

« Previous message in topic | 3 of 3 | Next message in topic »

Messages

Show all messages in topic

8.0 client crashing w/ 1.4.4rc1 Server running on 7.3 Erik Williamson <erik at cpsc dot ucalgary dot ca> Erik Williamson <erik at cpsc dot ucalgary dot ca> 2003-05-30 10:01:51 PDT
     Re: 8.0 client crashing w/ 1.4.4rc1 Server running on 7.3 Draco Benden <sschmit at cfl dot rr dot com> Draco Benden <sschmit at cfl dot rr dot com> 2003-05-30 10:25:19 PDT
         RE: 8.0 client crashing w/ 1.4.4rc1 Server running on 7.3 Erik Williamson <erik at cpsc dot ucalgary dot ca> Erik Williamson <erik at cpsc dot ucalgary dot ca> 2003-05-30 12:58:32 PDT
Messages per page: