Login | Register
My pages Projects Community openCollabNet

Discussions > users > python issues ?

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

Back to topic list

python issues ?

Reply

Author "Ryan M dot " <ryan at r-fx dot net>
Full name "Ryan M dot " <ryan at r-fx dot net>
Date 2003-03-05 11:03:52 PST
Message I get the following python errors while running the 'cadmin create'
option, any help would be appreciated:
 
root@vulcan [/etc/current]# cadmin -v -c /etc/current/current.conf
create
error: read failed: Is a directory (21)
Mar 05 13:3703 : EXCEPTION in /usr/share/current/channel.py,
_getHeaderFromFilename(), 597 [logException()]
Traceback (innermost last):
  File "/usr/share/current/​channel.py", line 594, in
_getHeaderFromFilename
    (header, isSource) = rpm.headerFromPackage(fd)
rpm.error: error reading package
Mar 05 13:37:03 Warning: Could not open package /home/rhup/7.2/custom
error: read failed: Is a directory (21)
Mar 05 13:3703 : EXCEPTION in /usr/share/current/channel.py,
_getHeaderFromFilename(), 597 [logException()]
Traceback (innermost last):
  File "/usr/share/current/​channel.py", line 594, in
_getHeaderFromFilename
    (header, isSource) = rpm.headerFromPackage(fd)
rpm.error: error reading package
Mar 05 13:37:03 Warning: Could not open package /home/rhup/7.2/srpm
error: read failed: Is a directory (21)
Mar 05 13:3703 : EXCEPTION in /usr/share/current/channel.py,
_getHeaderFromFilename(), 597 [logException()]
Traceback (innermost last):
  File "/usr/share/current/​channel.py", line 594, in
_getHeaderFromFilename
    (header, isSource) = rpm.headerFromPackage(fd)
rpm.error: error reading package
Mar 05 13:37:03 Warning: Could not open package /home/rhup/7.2/rpm
Mar 05 13:37:03 Adding gcc-c++-2.96-112.7.2.i386.rpm
Mar 05 13:37:03 Adding cpp-2.96-112.7.2.i386.rpm
Mar 05 13:37:03 Adding mutt-1.2.5.1-1.i386.rpm
Mar 05 13:37:03 Adding gcc-2.96-112.7.2.i386.rpm
Mar 05 13:37:03 Adding eel-1.0.2-2.i386.rpm
Etc..
 
Running the following software on my redhat 7.2 server:
mod_python-2.7.8-1
apache-1.3.27
python-1.5.2-43.72
python2-2.1.3-1
up2date-2.8.39-1.7.2
rhn_register-2.8.27-1.7.2
 
When I run up2date -l I get:
root@vulcan [/etc/current]# up2date -l
Error communicating with server. The message was:
Broken response from the server.
 
I have the current.httpd.conf included in my httpd.conf , all seems fine
in those respects. If there is more info I can give you let me know ?
Attachments

« Previous message in topic | 1 of 3 | Next message in topic »

Messages

Show all messages in topic

python issues ? "Ryan M dot " <ryan at r-fx dot net> "Ryan M dot " <ryan at r-fx dot net> 2003-03-05 11:03:52 PST
     Re: python issues ? jwbernin John Berninger 2003-03-05 11:33:34 PST
         RE: python issues ? "Ryan M dot " <ryan at r-fx dot net> "Ryan M dot " <ryan at r-fx dot net> 2003-03-05 12:08:48 PST
Messages per page: