Login | Register
My pages Projects Community openCollabNet

Discussions > issues > [Issue 31] New - current 1.6.0 will NOT work with MySQL 5.0

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

Back to topic list

[Issue 31] New - current 1.6.0 will NOT work with MySQL 5.0

Reply

Author iainf
Full name Iain Frerichs
Date 2005-04-15 12:43:31 PDT
Message http://current.tigri​s.org/issues/show_bu​g.cgi?id=31
                  Issue #:|31
                  Summary:|current 1.6.0 will NOT work with MySQL 5.0
                Component:|documentation
                  Version:|unspecified
                 Platform:|All
               OS/Version:|All
                      URL:|
                   Status:|NEW
        Status whiteboard:|
                 Keywords:|
               Resolution:|
               Issue type:|DEFECT
                 Priority:|P3
             Subcomponent:|configuration
              Assigned to:|jwbernin
              Reported by:|iainf






------- Additional comments from iainf at tigris dot org Fri Apr 15 12:43:31 -0700 2005 -------
The documentation states that you can use MySQL as the backend database, and
suggests using 4.x or later.

Version 1.6.0 does not work with version 5 (specifically 5.0.3) as the column
name "release" is a reserved word. This is in the "PACKAGE" table.

I actually got round this by altering the column name to "pkgrelease" in
db/mysql/schema.py and db/currentdb.py, and I am still testing that I have not
ruined everything. There is no MySQL subcomponent for me to enter this as a
backend issue...

FYI my setup:
RedHat Enterprise 3ES
+ MySQL 5.0.3 Beta from MySQL RPMs
+ MySQL-python-1.2.0 built against v14 MySQL client
+ current-1.6.0-1 installed from RPM.

--------------------​--------------------​--------------------​---------
To unsubscribe, e-mail: issues-unsubscribe@c​urrent.tigris.org
For additional commands, e-mail: issues-help at current dot tigris dot org

« Previous message in topic | 1 of 1 | Next message in topic »

Messages

Show all messages in topic

[Issue 31] New - current 1.6.0 will NOT work with MySQL 5.0 iainf Iain Frerichs 2005-04-15 12:43:31 PDT
Messages per page: