Login | Register
My pages Projects Community openCollabNet

Discussions > dev > Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0

Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Discussion topic

Back to topic list

Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0

Reply

Author Roland Pope <rpope at jadeworld dot com>
Full name Roland Pope <rpope at jadeworld dot com>
Date 2004-11-16 15:43:54 PST
Message ----- Original Message -----
From: "Jack Neely" <jjneely at gmail dot com>
> There's a patch on the CVS list that will correct the tracebacks in
> regards to concatinating a tuple. I need to get off my lazy rear and
> make a new release with that patch in it.
Jack,

I applied the following patch, installed the new version restarted httpd but
it still produced the same error saying "can only concatenate list (not
"tuple") to list"
<snip>
--- trunk/current/src/xmlrpc.py 2004-10-19 03:15:12 UTC (rev 635)
+++ trunk/current/src/xmlrpc.py 2004-11-02 20:38:47 UTC (rev 636)
@@ -62,6 +62,7 @@
     fd.write(xmlheader)
     fd.write("<method​Response>\n")
     fd.write("<params​>\n<param>​\n")
+ fd.write("<value​><array><​data>\n")

     # don't suck the entire data set into memory at once
     row = cursor.fetchone()
@@ -78,6 +79,7 @@

         row = cursor.fetchone()

+ fd.write("</data​></array>​</value>\n")
     fd.write("</param​>\n</params​>\n")
     fd.write("</metho​dResponse>\n")
</snip>
> As far as the dependancy problem does this include custom packages or
> just stock Whitebox? What exact packages?

The package in question was a custom build of Net_SSLeay.
 Doing the same update using the old 1.4 relase of current worked fine.
One thing I noted here, was that under current-1.4, there were no additional
dependancies required when I uninstalled the old perl-Net-SSLeay with
rpm --nodeps and installed the new perl-Net_SSLeay using 'up2date
perl-Net_SSLeay'.
When I tried the same thing under current-1.5, the 'up2date perl-Net_SSLeay'
installs 3 devel packages, which I know are required for the build, but not
for the install. So perhaps the dependancies stuff is mucked up on the
server, or maybe it relates to the 'tuple' error and the client is not
sucessfully downloading everything it needs becasue of this.
Anyway, let me know if there is anything else I can do to diagnose this
further.

>Can you crank up the logging and post the Current's logs of that
transaction?

See attached (This is the log created after the xmlrpc patch was applied).

Thanks
Roland
Attachments

« Previous message in topic | 6 of 8 | Next message in topic »

Messages

Show all messages in topic

Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 Roland Pope <rpope at jadeworld dot com> Roland Pope <rpope at jadeworld dot com> 2004-11-15 19:55:19 PST
     Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 Roland Pope <rpope at jadeworld dot com> Roland Pope <rpope at jadeworld dot com> 2004-11-15 20:48:55 PST
         Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 theslack Jack Neely 2004-11-16 06:36:25 PST
             Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 Roland Pope <rpope at jadeworld dot com> Roland Pope <rpope at jadeworld dot com> 2004-11-16 13:26:27 PST
                 Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 Roland Pope <rpope at jadeworld dot com> Roland Pope <rpope at jadeworld dot com> 2004-11-16 13:46:51 PST
             Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 Roland Pope <rpope at jadeworld dot com> Roland Pope <rpope at jadeworld dot com> 2004-11-16 15:43:54 PST
                 Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 Roland Pope <rpope at jadeworld dot com> Roland Pope <rpope at jadeworld dot com> 2004-11-16 19:43:10 PST
                     Re: Problems with up2date-4.3.19 and current-1.5.7 on whitebox 3.0 theslack Jack Neely 2004-11-22 17:24:13 PST
Messages per page: