Login | Register
My pages Projects Community openCollabNet
Project highlights: Stable Version: 1.6.1, Development Version: 1.7.6

current
Reply to message

* = Required fields
* Subject
* Body
Attachments
Send reply to
Topic
Author (directly in email)
Please type the letters in the image above.

Original message

Author Jared Greenwald <greenwaldjared@gmail.com>
Full name Jared Greenwald <greenwaldjared@gmail.com>
Date 2007-11-29 06:24:14 PST
Message On Nov 29, 2007 9:15 AM, Darryl Plank <Darryl dot Plank at aems dot net> wrote:
> >> What user are you connecting as when you were testing the connection
> earlier? <<
>
> I tried both "root" and "postgres", but mostly I used "postgres".

If postgres worked for you earlier when you tested the connection
through python, then you should use that. Your problems might be
linked to what you are mentioning below.

>
> >> Why not just put cadmin somewhere that IS in your path? I personally
> have it as /usr/bin/cadmin (or /usr/bin/cadmin.py). It really doesn't
> matter where the cadmin command is at in the filesystem because the
> whole of current is in the site-packages directory which is part of
> the python path. This means that the import statements in the current
> files will work no matter where cadmin is. <<
>
> On my system, "cadmin" and "cadmin.py" are two different files. "cadmin"
> *is* in my path, but "cadmin.py" is with the rest of the python files in
> "/usr/share/current" (as specified in the documentation).
>
> When I execute cadmin.py, the import statements are not working. Perhaps
> this means there's something wrong with my python path ...

If you open up a python shell and try to import anything from current,
do you get an error? Something like...

from current.cadmin import *

anything really...

>
>
>
>
> --------------------​--------------------​--------------------​---------
> To unsubscribe, e-mail: users-unsubscribe@cu​rrent.tigris.org
> For additional commands, e-mail: users-help at current dot tigris dot org
>
>